preloder

Exemplos para praticar no VisuAlg

Segue alguns exemplos de programas para praticar no VisuAlg.

1) Este exercício é apenas um desafio de lógica. Escreva um algoritmo que armazene o valor 10 em uma variável A e o valor 20 em uma variável B. A seguir (utilizando apenas atribuições entre variáveis) troque os seus conteúdos fazendo com que o valor que está em A passe para B e vice-versa. Ao final, escrever os valores que ficaram armazenados nas variáveis.

2)  Escreva um algoritmo para ler as dimensões de um retângulo (base e altura), calcular e escrever a área do retângulo.  Sabendo que para calcular a área devemos usar a formula a seguir;

 

3)  Faça um algoritmo que leia a idade de uma pessoa expressa em anos, meses e dias e escreva a idade dessa pessoa expressa apenas em dias. Considerar ano com 365 dias e mês com 30 dias.

Soluções dos algoritmos.

Exercício 1

Algoritmo "Troca de Valores"
Var
a, b, intermediario: inteiro // crie duas variáveis do tipo inteiro.

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...

Escreva("Olá, digite um valor para A:")
leia(a)

Escreva("Olá de novo, digite agora outro valor para B:")
leia(b)

// Exibe para o usuário os valores digitados.
Escreva("Muito bem! Você digitou os valores para A:", a, " e B:", b)

// Fazemos a troca dos valores das variáveis,
// precisamos de uma veriável intermediária para fazer a troca
intermediario <- a
a <- b
b <- intermediario

Escreva("Se invertermos os valores de A e B teremos A:", a, " e B:", b)

Fimalgoritmo

Exercício 2

Algoritmo "Triangulo Calculator 3100"
Var
base, altura, area: real // crie duas variáveis do tipo inteiro.

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...

Escreval("************** SUPER TRIANGULO CALCULATOR 3100 ************** ")
Escreval()
Escreval()

Escreva("Olá, informe a base do triângulo:")
leia(base)

Escreva("Olá, informe a altura do triângulo:")
leia(altura)

area <- (base * altura)/2

Escreva("Esse triangulo tem uma área de ", area)

Fimalgoritmo

Exercício 3

Algoritmo "IDADE CALCULATOR 5600"
Var
diaNascimento, mesNascimento, anoNascimento: inteiro
calculaAno, calculaMes, calculaDias: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...

Escreval("************** SUPER IDADE CALCULATOR 5600 ************** ")
Escreval()
Escreval()

Escreval("Digite o dia em que nasceu: ")
leia(diaNascimento)

Escreval("Digite o mes em que nasceu (digite o mês em número, de 1 à 12): ")
leia(mesNascimento)

Escreval("Digite o ano em que nasceu: ")
leia(anoNascimento)

Escreval("******************************************************** ")

calculaAno <- (2017 - anoNascimento) * 365
calculaMes <- (mesNascimento * 30) - (30 - diaNascimento)
calculaDias <- CalculaAno + calculaMes

Escreva("Você possui", calculaDias, " dias de vida")
Escreval()
Escreval()

Fimalgoritmo

Deixe seu comentário