Ads

Em Lógica de Programação existem os laços de repetição, sendo que o mais comuns que encontramos nas linguagens comerciais como C#, Java, PHP, JavaScript são o while (enquanto), do while (faça enquanto) e for (para).

Neste artigo vou demonstrar o uso do enquanto (while), A ideia deste laço de repetição, como o próprio nome sugere é repetir um terminado bloco de comandos até que se chegue a um determinado valor.

Para que estes laços de repetição funcionem bem, na maioria dos casos usamos junto um acumulador, trata-se de uma variável especial que irá contar quantas vezes o bloco de comando foi repetido.

A partir do valor desta variável acumulador que podemos definir quando o laço deve parar de repetir os comandos.

A sintaxe da estrutura enquanto no VisuALG é

enquanto <expressão-lógica> faca
   <seqüência-de-comandos>
fimenquanto

Este é um algoritmo que resolve 3 exemplos mostrados na aula;

Algoritmo "Exemplos de laços de repetição usando o ENQUANTO"

Var
num, n, idade:inteiro
soma:real;
nome:caractere;

Inicio

// EXIBIR OS 100 PRIMEIROS NÚMEROS.
escreval("Exibir os 100 primeiros números")
num <- 0
enquanto (num <= 10) faca
 escreval(num)
 num <- num + 1
fimenquanto

// CALCULO DA MÉDIA.
escreval("*****************************")
escreval("Calcular a média de 5 números")
num <- 0
enquanto (n<5) faca
 escreva("Digite um número: ")
 leia (num)
 soma <- soma + num
 n <- n+1
fimenquanto
escreval("Média = ", soma/5)

// VERIFICA A MAIORIDADE DE 5 PESSOAS
escreval("*****************************")
escreval("Verificar maioridade de 5 pessoas")
n <-0
enquanto (n<5) faca
 escreva("digite o nome do aluno:")
 leia(nome)
 escreva("digite a idade:")
 leia(idade)
 
 se (idade < 18) entao
 escreva(nome, " você é menor de idade")
 senao
 escreva(nome, " você é maior de idade")
 fimse
fimenquanto
Fimalgoritmo

Exemplos Visualg para praticar

Se você quer mais exemplos, acesse este outro artigo – Exemplos para praticar no VisuAlg, nele você encontrará exemplos resolvidos e terá acesso a exercícios compartilhados na minha conta do OneDrive. Bons estudos.

Ads